Issue with STORJ payments
Incident Report for Tardigrade
Resolved
This incident has been resolved.
Posted Dec 18, 2019 - 19:41 UTC
Update
We are continuing to investigate this issue.
Posted Dec 18, 2019 - 17:49 UTC
Investigating
We're currently tracking an issue with our STORJ payment provider.
Posted Dec 18, 2019 - 16:19 UTC
This incident affected: Asia-East-1 (Asia-East-1 Billing), Europe-West-1 (Europe-West-1 Billing), and US-Central-1 (US-Central-1 Billing).