Credit Card Billing Problems
Incident Report for Tardigrade
Resolved
Credit Card billing is working again.
Posted Jan 17, 2020 - 14:54 UTC
Update
We're still waiting to hear back from our payment provider about this issue.
Posted Jan 13, 2020 - 15:52 UTC
Identified
We've confirmed that problem is isolated to the Europe-West-1 location
Posted Jan 02, 2020 - 22:23 UTC
Investigating
We're investigating an issue with credit card billing on Europe-West-1.
Posted Jan 02, 2020 - 21:29 UTC
This incident affected: Europe-West-1 (Europe-West-1 Billing).